Вышел PyDev 5.4.0, плагин для разработки на языке Python в Eclipse

12 месяцев ago admin 0

Доступен новый выпуск PyDev 5.4.0, плагина для поддержки Python в Eclipse. Для работы требуется Eclipse не ниже версии 4.6 (Neon) и Java 8.

Особенности релиза:

  • Начальная поддержка Python 3.6. Анализ кода для выражений в f-strings. Подсветка синтаксиса. Обработка подчёркивания в числовых литералах. Парсинг аннотаций переменных. Парсинг асинхронных генераторов и представлений.
  • Запуск. Улучшено консольное описание запуска. Поддержка запуска в формате python -m module.name вместо python module/name.py (Включается через опцию Preferences > PyDev > Run)
  • Отладчик. Отображение возвращаемых значений. При ожидании пользовательского ввода, больше нет попыток обработать введённое содержимое. Исправление мультипроцессной отладки, когда отладчик запускается с программной точкой остановки (pydevd.settrace).
  • Интеграция с модульными тестами. Исправлены ошибки связанные с юникодом. Подтесты теперь правильно обрабатываются исполнителем юниттестов. Текущий выбор тестов сохраняется.
  • Прочее. В Linux, когда выполняется автозавершение кода для автодобавления импорта, если пользователь фокусируется на всплывающем окне (нажатием Tab) и применяет автодополнение нажатием Shift+Enter, локальный импорт выполняется правильно.

Средства на развитие плагина собираются через краудфандинг.


Source: pirates.in.ua