В Asterisk 14.4.1 и 13.15.1 устранены опасные уязвимости

3 месяца ago admin 0

В корректирующих выпусках коммуникационной платформы Asterisk 14.4.1 и 13.15.1 устранены три уязвимости, которым присвоен наивысший уровень опасности:

  • Переполнение буфера в обработчике PJSIP, позволяет вызвать крах или потенциально выполнить код (возможность данного вида эксплуатации пока не подтверждена) через отправку неаутентифицированного SIP-пакета со специально изменёнными заголовками CSeq и Via. Проблеме не подвержены конфигурации Asterisk с chan_sip;
  • Ошибка в парсере комбинированных (multi-part) запросов PJSIP позволяет осуществить чтение из области вне буфера и вызвать крах через удалённую отправку специально оформленных пакетов;
  • Ошибка в канальном драйвере chan_skinny позволяет исчерпать всю доступную Asterisk память через отправку специально оформленного SCCP-пакета из-за зацикливания, если размер пакета больше размера заголовка, но меньше чем размер, указанный в заголовке.


Source: pirates.in.ua